Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 [3] 4 5 ... 10
 21 
 on: Yesterday at 08:21:19 PM 
Started by fatboybrian - Last post by fatboybrian
Just picked up a 07 Springer with 9500 mile on it yesterday, bike is a blast to ride. Other than putting a decent set of lifters in it any preventive maintenance advice would be appreciated.

 22 
 on: Yesterday at 07:02:22 PM 
Started by TN - Last post by Mofo67
I watched it, very cool to see the baggers navigate a road course. Any word on what happened to the Indian? HD looked very strong from the beginning...

 23 
 on: Yesterday at 06:49:49 PM 
Started by TN - Last post by TN
Yes HD won one, good for them.  :2vrolijk_21:  Did anyone watch the race, I did.

I really like this series








 24 
 on: Yesterday at 05:28:51 PM 
Started by TN - Last post by YELLOWBIRD
#1, #2 #3 on the podium for MoCo Factory Race Team! Finally!

Relocating the oil cooler in the fake headlights assembly on the Factory Road Glides bikes. Making a difference.  :2vrolijk_21:


EDIT: Not relocated, but a additional oil cooler.




YB

 25 
 on: Yesterday at 04:36:22 PM 
Started by Jock - Last post by TN
You do get around Jock, good job.  :2vrolijk_21:

 26 
 on: Yesterday at 04:35:48 PM 
Started by ChopperPilot - Last post by kevin_n
That is absolutely worth a Congratulations!!  :drink:

Thanks Don. Hopefully we can set that money aside for a new truck now.

 27 
 on: Yesterday at 04:20:50 PM 
Started by fatboyse - Last post by Twolanerider
Harley had some issues with those switches in the past.  If you have thoroughly done all the possible troubleshooting of things outside the switch itself it sounds like you have already isolated the problem down to that.  Time to buy and replace a switch?

 28 
 on: Yesterday at 03:37:41 PM 
Started by fatboyse - Last post by fatboyse
I have researched this and know what it is but have no idea how to fix it. I have checked the wiring and did not see a problem.

 29 
 on: Yesterday at 03:16:25 PM 
Started by fatboyse - Last post by Twolanerider
That's a clutch switch code.  Switch shorted to ground.  That switch is to keep you from cranking the engine with the bike in gear and the clutch engaged.  Not an in use problem just a startup safety measure.

 30 
 on: Yesterday at 01:53:05 PM 
Started by fatboyse - Last post by fatboyse
Clear code and comes right back on, clutch switch still works, cruise still works.

Pages: 1 2 [3] 4 5 ... 10

Page created in 0.106 seconds with 18 queries.