Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: 2014 ultra starter dragging  (Read 394 times)

0 Members and 1 Guest are viewing this topic.

Newell Ron

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
  • www.CVOHARLEY.com
    • LA

2014 ultra starter dragging
« on: April 10, 2021, 05:18:57 PM »

New member here. Thought I'd ck y'all out. Got a problem with taking my bike to a shop so looking at you guys for an idea. New batt., new batt. cables new starter but (not everytime but most of the time ) the starter will drag the voltage down to nothing. It does start though. Usually if I bump the button first its ok then. Batt. shows 13+ stopped and 14.2 running. I can hear atleast one of the acr's click when I turn the switch on. This things got me buffaloed. 37k miles. Sure would appreciate ideas
Thanks again, Ronnie
Logged

ultra13

  • Senior CVO Member
  • ****
  • Offline Offline
  • Posts: 422
  • www.CVOHARLEY.com
    • OH


    • CVO1: 2013 CVO Ultra
Re: 2014 ultra starter dragging
« Reply #1 on: April 11, 2021, 08:50:37 AM »

You said you R2'd the starter. Does that include the starter clutch?
Logged

Newell Ron

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
  • www.CVOHARLEY.com
    • LA

Re: 2014 ultra starter dragging
« Reply #2 on: April 11, 2021, 11:00:40 AM »

Yep the whole assembly.
Logged

CVO Couple

  • Full CVO Member
  • ***
  • Offline Offline
  • Posts: 219
  • www.CVOHARLEY.com
    • SC


    • CVO1: 2015 FLHTKSE
    • CVO2: 2008 FXSTC Anniversary
Re: 2014 ultra starter dragging
« Reply #3 on: April 11, 2021, 05:34:21 PM »

Does the engine start turning over then hit a compression stroke and stop or almost stop then keep going and starts?


Sent from my iPhone using Tapatalk
Logged

Newell Ron

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
  • www.CVOHARLEY.com
    • LA

Re: 2014 ultra starter dragging
« Reply #4 on: April 11, 2021, 08:38:34 PM »

I fixed it !!!. (I think)   lol
The ACRs were the only thing I could figure so I put a whole bottle of that concentrated seafoam injector cleaner in a full tank and ran the heck out of it out on I 10 . Its been working fine (knock on wood)..
Logged

ultra13

  • Senior CVO Member
  • ****
  • Offline Offline
  • Posts: 422
  • www.CVOHARLEY.com
    • OH


    • CVO1: 2013 CVO Ultra
Re: 2014 ultra starter dragging
« Reply #5 on: April 12, 2021, 12:27:42 PM »

SAAAWEET!
Logged

Newell Ron

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
  • www.CVOHARLEY.com
    • LA

Re: 2014 ultra starter dragging
« Reply #6 on: April 12, 2021, 02:37:58 PM »

Thanks. I appreciate the input.
Ronnie
Logged
 

Page created in 0.114 seconds with 21 queries.