Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Clutch Bearing or Clutch Hub Bad?  (Read 373 times)

0 Members and 1 Guest are viewing this topic.

ltank

  • 1K CVO Member
  • *
  • Offline Offline
  • Posts: 1196
    • LA

    • CVO1: 2000 FXR4 S&S V111, CustomS.S. 2-1 exhaust, Primo-Rivera OD 6 speed, 49mm Custom Front End Ohlins 30mm Fork cartridges , Hyperpro Shocks, Barnett Scorpian Clutch
    • CVO2: 1983 88" Shovelhead Won the World of Wheels 1985 Sept 85 Issue of Hot Bike Mag
    • CVO3: 1989 FXRS, 1990 Custom 100" Shovelhead/ EVO
Clutch Bearing or Clutch Hub Bad?
« on: December 12, 2021, 03:05:12 PM »

Evolution Industries Stage-1 Terminator Clutch. The HD stock transmission Mainshaft nut is Tourqed to 75 ft/lbs. The Baker transmission Mainshaft does not wobble. Transmission and inner Primary bearing are good.
   With the nut tightened on shaft securing the clutch assembly there is wobble that can be seen just behind the nut. It almost looks as if the splined part of the hub is loose in the Hub? Would a bad clutch hub bearing give the same visual of problem?
  I can't feel any play between the Hub and the Basket. This tells me the Clutch Hub bearing is good.
 I sent it back for inspection and repair. I will know after they get back to me but, it's driving me Nuts not knowing what the problem is. Pic is one online.
Part already shipped back.
Thanks
« Last Edit: December 12, 2021, 03:07:50 PM by ltank »
Logged
 

Page created in 0.1 seconds with 21 queries.