Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Radio on my 08  (Read 1045 times)

0 Members and 1 Guest are viewing this topic.

rayz1951

  • Full CVO Member
  • ***
  • Offline Offline
  • Posts: 185
    • MI

Radio on my 08
« on: March 29, 2009, 03:06:02 PM »

I'm having problems with my radio fading in and out.  It happened last year a few times but then nothing for a while.  It's started again recently so I took it to the dealer.  They said they will plug in the computer to it and see if it shows anything.  One dealer said they would take it out, send it back and H. D. would replace it.  It's not the reception because it happens with the c. d. player also.  Is anyone else experiencing this problem? 

The dealer that said they would replace it had to send the old one in before H. D. would send them the new one back.  I don't like the fact, I would have to ride around with a hole in my fairing  untill Harley sent back the new or rebuilt one back.  I hope they can fix it without sending it in!
Logged
RayZ

Jrblu

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
  • www.CVOHARLEY.com
    • MO

Re: Radio on my 08
« Reply #1 on: July 04, 2024, 05:47:55 PM »

Mine done the same thing.. the radios are known for this... what caused mine was the triple tree bolts were to tall so pull the radio out an you will see... took my angelgrinder an grinded the top of them down an works fine
Logged
 

Page created in 0.147 seconds with 20 queries.