Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 [2] 3  All

Author Topic: 2014 Limited Check engine light, red temperature light P1019  (Read 7560 times)

0 Members and 2 Guests are viewing this topic.

shaochieh.young

  • Newbie
  • *
  • Offline Offline
  • Posts: 26
  • www.CVOHARLEY.com

Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #15 on: May 19, 2018, 03:39:18 PM »

The magnet cracked on the inside and no way to repair this one.  Got a new one on the way.


Sent from my iPhone using Tapatalk
Logged

RonandJanet

  • 1K CVO Member
  • *
  • Offline Offline
  • Posts: 1207
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #16 on: May 20, 2018, 12:18:04 PM »

I know that sucks.  Gald you found the problem. How long does it take for you get parts?
Logged

shaochieh.young

  • Newbie
  • *
  • Offline Offline
  • Posts: 26
  • www.CVOHARLEY.com

Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #17 on: May 20, 2018, 12:29:26 PM »

Hope this week.  Takes 5-7 days from the states to Germany.


Sent from my iPhone using Tapatalk
Logged

RonandJanet

  • 1K CVO Member
  • *
  • Offline Offline
  • Posts: 1207
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #18 on: May 21, 2018, 10:07:17 PM »

Well that isn't as bad as I thought it may be.  Hopefully in less time!
Logged

fos41

  • Full CVO Member
  • ***
  • Offline Offline
  • Posts: 191
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #19 on: July 02, 2019, 08:43:42 AM »

Hello all have a `15 S.E.S.G. with similar symptoms check engine light on and the temp. light is on on the right. Dumb question here how can you tell, if the water pump is running cooling fans run as described in this  post, but cannot be sure pump is running or not b/c of the fan noise.
Logged

Boatman

  • 2.5K CVO Member
  • **
  • Offline Offline
  • Posts: 4757
  • FLHRSEI.ORG

    • CVO1: 2014 CVO Limited
    • CVO2: 2010 SEUC-accident victim-gone
    • CVO3: 2005 SEEG-traded on 2010
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #20 on: July 02, 2019, 04:21:18 PM »

Remove the chrome cover and put your hand on the pump and you can feel the pump running. Hope this helps.
Logged

grc

  • 10K CVO Member
  • ****
  • Offline Offline
  • Posts: 14216
  • AKA Grouchy Old Fart
    • IN


    • CVO1: 2005 SEEG2
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #21 on: July 02, 2019, 05:43:06 PM »


Depending on what actually failed (pump motor or the impeller drive), just feeling for motor vibration may not tell you what you need to know.  You need to verify that coolant is actually flowing.

Jerry
Logged
Jerry - 2005 Cherry SEEG  -  Member # 1155

H-D and me  -  a classic love / hate relationship.  Current score:  love 40, hate 50, bewildered 10.

Boatman

  • 2.5K CVO Member
  • **
  • Offline Offline
  • Posts: 4757
  • FLHRSEI.ORG

    • CVO1: 2014 CVO Limited
    • CVO2: 2010 SEUC-accident victim-gone
    • CVO3: 2005 SEEG-traded on 2010
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #22 on: July 02, 2019, 06:06:49 PM »

Depending on what actually failed (pump motor or the impeller drive), just feeling for motor vibration may not tell you what you need to know.  You need to verify that coolant is actually flowing.

Jerry

Yes as Jerry stated it will tell you if running but not pumping.  I took old one a part but saw nothing wrong but doing ok now since replacing.   Knock wood.  Sad thing is I’ll be doing again as I still have the old style pump.  Sumbitches wouldnt release new pump til old stock was depleted.  Same thing with compensators a few year ago.   :soapbox:
Logged

fos41

  • Full CVO Member
  • ***
  • Offline Offline
  • Posts: 191
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #23 on: July 03, 2019, 06:40:11 PM »

Does anyone know how to find a wiring schematic for the pump and fans online I do not have a service manual. Bought a new temp switch installed, pulled water pump to visually test it`s operation, fans and pump ran for a second w/ switch on and throttle rolled open then stopped and neither fan(s) or pump works don`t you love a mystery. Any input appreciated i`m at a lost.
Logged

grc

  • 10K CVO Member
  • ****
  • Offline Offline
  • Posts: 14216
  • AKA Grouchy Old Fart
    • IN


    • CVO1: 2005 SEEG2
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #24 on: July 04, 2019, 09:22:41 AM »

See if the attachment helps.

Jerry

I forgot to mark the temp sensor - it's called the ECT and it's shown next to the left cooling fan.
« Last Edit: July 04, 2019, 09:27:14 AM by grc »
Logged
Jerry - 2005 Cherry SEEG  -  Member # 1155

H-D and me  -  a classic love / hate relationship.  Current score:  love 40, hate 50, bewildered 10.

fos41

  • Full CVO Member
  • ***
  • Offline Offline
  • Posts: 191
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #25 on: July 04, 2019, 10:06:07 AM »

Thank you Jerry.
Logged

fos41

  • Full CVO Member
  • ***
  • Offline Offline
  • Posts: 191
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #26 on: July 05, 2019, 01:13:08 PM »

Figured some things out on my water pump debacle yesterday after removing pump, it and fans ran for only a second. Discovered blown fan fuse tried one more fuse and immediate blew again when turning on switch-opening throttle attempting to turn fans on, I disconnected pump wire and eliminated the dead short caused by the pump.

Had the same code others mentioned here P1019 and P1691 & 1693 I induced when disconnecting fans testing. How do you clear the trouble codes?

$377.00 later have a new updated water pump kit hope it is a fairly straight forward installation. Thank you guys for all of your input here.

Donnie













Logged

CircleRacer

  • Senior CVO Member
  • ****
  • Offline Offline
  • Posts: 363
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #27 on: July 05, 2019, 01:47:06 PM »

Not at all hard to install completed changing my last week

Sent from my moto z3 using Tapatalk

Logged

shaochieh.young

  • Newbie
  • *
  • Offline Offline
  • Posts: 26
  • www.CVOHARLEY.com

Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #28 on: July 06, 2019, 02:37:01 AM »

Not at all hard to install completed changing my last week

Sent from my moto z3 using Tapatalk
Dose the lower faring needs to come off?


Sent from my iPhone using Tapatalk
Logged

CircleRacer

  • Senior CVO Member
  • ****
  • Offline Offline
  • Posts: 363
Re: 2014 Limited Check engine light, red temperature light P1019
« Reply #29 on: July 06, 2019, 05:15:18 AM »

Yes both lowers have to come off because you have to change the hoses that connect to the bottom of both left and right radiators.

Sent from my moto z3 using Tapatalk

Logged
Pages: 1 [2] 3  All
 

Page created in 0.14 seconds with 24 queries.