Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Electrical Headache  (Read 773 times)

0 Members and 1 Guest are viewing this topic.

Foggy@times

  • #iGotThis
  • Newbie
  • *
  • Offline Offline
  • Posts: 5
  • www.CVOHARLEY.com
    • NJ


    • CVO1: Late 85 FXRT Sport Glide
Electrical Headache
« on: March 20, 2017, 01:15:11 AM »

First off I apologize if someone asked this similar question, but I could not find it, so here goes. I recently replaced the main wiring harness and the handlebar harness on my late 85 FXRT Sport Glide, where Im getting caught up is the speedo/tach has a connector box on it that neither harness has and I don't know the part number or what to call it (pics included). Does anyone know where I go from here?

Logged
No windshield please, I'm chasing ghosts

ltank

  • 1K CVO Member
  • *
  • Offline Offline
  • Posts: 1022
    • LA

    • CVO1: 2000 FXR4 S&S V111, CustomS.S. 2-1 exhaust, Primo-Rivera OD 6 speed, 49mm Custom Front End Ohlins 30mm Fork cartridges , Hyperpro Shocks, Barnett Scorpian Clutch
    • CVO2: 1983 88" Shovelhead Won the World of Wheels 1985 Sept 85 Issue of Hot Bike Mag
    • CVO3: 1989 FXRS, 1990 Custom 100" Shovelhead/ EVO
Re: Electrical Headache
« Reply #1 on: March 20, 2017, 06:48:55 AM »

Your best bet is to get a OEM FXRT Service Manual. Or to a Old Harley mechanic that has done it all. Harley had kept wire functions and the color codes the same for many years for the sole purpose of troubleshooting electrical issues.
Logged

Ironhorse

  • Vendor
  • 2.5K CVO Member
  • *
  • Online Online
  • Posts: 3493

    • CVO1: 2006 SE Ultra
Re: Electrical Headache
« Reply #2 on: March 20, 2017, 02:19:39 PM »

Foggy,

I have found a good source for technical support to be: www.harleytechtalk.com. Hopefully they can help you get things squared away.

Mark
Logged
"But men are men, the best sometimes forget" Shakespeare, Othello Act 2, Scene 3

Foggy@times

  • #iGotThis
  • Newbie
  • *
  • Offline Offline
  • Posts: 5
  • www.CVOHARLEY.com
    • NJ


    • CVO1: Late 85 FXRT Sport Glide
Re: Electrical Headache
« Reply #3 on: March 20, 2017, 07:09:27 PM »

Thanks guys, I'll keep you updated
Logged
No windshield please, I'm chasing ghosts

hd-dude

  • Global Moderator
  • 5k CVO Member
  • *****
  • Offline Offline
  • Posts: 6513
  • 2005 Cherry FLHTCSE2 "Obsession"

    • CVO1: 05 FLHTCSE2
    • Metal Dragon
Re: Electrical Headache
« Reply #4 on: March 21, 2017, 12:02:05 AM »

That is not a factory connector.

Foggy@times

  • #iGotThis
  • Newbie
  • *
  • Offline Offline
  • Posts: 5
  • www.CVOHARLEY.com
    • NJ


    • CVO1: Late 85 FXRT Sport Glide
Re: Electrical Headache
« Reply #5 on: July 17, 2017, 03:41:33 AM »

I just got all my factory parts on thanks to Nicks Customs.. now I have a new issue. I'm not sure what side of the relay (the battery or aux side)  each of the harness lines go to. Any ideas?? I'm getting a relay click meaning I fudged up somewhere
Logged
No windshield please, I'm chasing ghosts
 

Page created in 0.109 seconds with 25 queries.