Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Need some help or advice  (Read 60 times)

chaos901 and 1 Guest are viewing this topic.

2k

  • My ignorance is just as good as your knowledge, when my information changes, I alter my conclusions
  • 5k CVO Member
  • ***
  • Offline Offline
  • Posts: 7859
  • monter le cheval de fer (French)
    • NC


    • CVO1: 2013 SERK-Dressed in BLUE of course.
    • CVO2: 2002 Supercharged HD F150 512 RWHP
    • CVO3: 1956 BelAir Sports Coupe
Need some help or advice
« on: Today at 11:12:35 AM »

In Sturgis, so long way from home. '09  SE Ultra coming home last night and lost throttle. Motor still running but no throttle response at all. Switched off and sat for 2/3 minutes will scratching head. Cranked back up..all good. Went about 5 miles, repeated. this time went only about 1 mile, same. 8 miles from house so 3 of us go to get trailer so as not to damage anything worse. We pull in and a minute later broke bike pulls in, says he wanted to try one more time and it ran perfect 8 miles to house. Anybody have a clue? Suspecting fly-by-wire but don't know where to start! Hints welcome.
Logged
"When I die, I want to go peacefully like my Grandfather did, in his sleep -- not screaming, like the passengers in his car."

OBB

  • 2.5K CVO Member
  • **
  • Offline Offline
  • Posts: 4556
  • aka Ohiobellboy
    • OH


    • CVO1: 2011 Slate/Black SERGU** traded
    • CVO2: 2015 Double Blue SERGU
    • CVO3: 2012 SERG Blue
Re: Need some help or advice
« Reply #1 on: Today at 03:21:14 PM »

Check the throttle body wiring.

Sent from my boring Droid phone.

Logged
PHOTOBUCKET IS HOLDING MY PIX HOSTAGE!!!
 

Page created in 0.114 seconds with 25 queries.