Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: 2009 Fxstsee3 Led Tailight  (Read 2417 times)

0 Members and 1 Guest are viewing this topic.

TLC

  • Junior CVO Member
  • **
  • Offline Offline
  • Posts: 54

    • CVO1: 09 FXSTSSE3
2009 Fxstsee3 Led Tailight
« on: September 26, 2014, 10:58:03 PM »

My Led tailight on my 2009 cvo Springer is on brakelight all the time.I had it replaced once already within the 2 year warranty.Does the extended warranty cover this again.If not where is the best place to get this as it is all 1 unit together.Part # 68349-07D.Any place cheaper than a dealer?
Logged

Woof

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
  • www.CVOHARLEY.com
Re: 2009 Fxstsee3 Led Tailight
« Reply #1 on: September 29, 2014, 03:53:36 PM »

Mine only works when you hit a bump
Logged

DarkEagle

  • Junior CVO Member
  • **
  • Offline Offline
  • Posts: 92

    • CVO1: 2009 FXSTSSE3 Black Diamond with Emerald Ice Flames
Re: 2009 Fxstsee3 Led Tailight
« Reply #2 on: October 15, 2014, 08:51:16 AM »

the brake light on mine would stay on a lot from front brake handle grip not returning back off of the brake light switch in the handlebar assembly. they fixed it on warranty by replacing master cylinder but it's back. when front pads needed replacing worked the brake lever & master cylinder a bit when bleeding line so it does not stick as much but think front master cylinder needs stronger internal spring, need to also consider disassembling front brake handle & switch assembly & re-lube. rear brake master cylinder & switch works just fine.
Logged

Sinker

  • Junior CVO Member
  • **
  • Offline Offline
  • Posts: 88
Re: 2009 Fxstsee3 Led Tailight
« Reply #3 on: February 13, 2015, 08:09:57 AM »

Mine had the same issue. I took it to the local dealer and they replaced it under the extended warranty that only had a few months left on it. It creates a pretty dangerous situation when drivers behind you don't know you are slowing down. I almost got tail ended by my riding buddy who did not realize the light was out. I think this is a pretty common issue with these bikes.
Logged

gmeikle

  • Full CVO Member
  • ***
  • Offline Offline
  • Posts: 242
  • 2008 FXSTSSE2

    • CVO1: 2008 FXSTSSE2 Diamond Black
Re: 2009 Fxstsee3 Led Tailight
« Reply #4 on: April 20, 2015, 09:02:29 AM »

Just yesterday I removed the tri bar LED rear light from my 2008 FXSTSSE2

Light had been "flickering" for long and weary , then stopped working either brake or taillight

The unit is not supposed to be user serviceable , but I "persisted" like a Scotsman ( I am a Scotsman FFsake !!)

Unbolt the unit with the 4 x 9/16 bolts under the fender , and the 2 Allen bolts from the rear

Cut the outer lens cover out of it's silicone jacket and pulled out the LED's and the circuit board

Sure enough , broken joints at the female connector to the circuit board.

Soldered with fine "silver solder" wire , rebuilt with windscreen ( sorry "windshield" haha) silicone sealant

carefully reassembled with electrical clean and lube on the wires and connectors

Working all good now , you can "tap" the light unit and no "flickering"

Only labour , your time , and a wee bit of materials.

It's a $300 light unit here in Perth Western Australia to order it from the HD dealer
Logged
No illegitimi carborundum

08CVOSPRNGER

  • Junior CVO Member
  • **
  • Offline Offline
  • Posts: 93
Re: 2009 Fxstsee3 Led Tailight
« Reply #5 on: May 05, 2015, 07:04:01 PM »

My 08 started doing this same thing this past weekend. I took it apart and the connector on the circuit board that the l.e.d. plugs in had came loose from the board. Quick solder job and resealed with silicone. Good as new.
Logged

cossack

  • Newbie
  • *
  • Offline Offline
  • Posts: 38
  • www.CVOHARLEY.com

Re: 2009 Fxstsee3 Led Tailight
« Reply #6 on: March 08, 2016, 04:52:59 AM »

thanks for the info.
finally pulled the light apart and had it re-soldered ( middle connector on the voltage regulator )
all good


Just yesterday I removed the tri bar LED rear light from my 2008 FXSTSSE2

Light had been "flickering" for long and weary , then stopped working either brake or taillight

The unit is not supposed to be user serviceable , but I "persisted" like a Scotsman ( I am a Scotsman FFsake !!)

Unbolt the unit with the 4 x 9/16 bolts under the fender , and the 2 Allen bolts from the rear

Cut the outer lens cover out of it's silicone jacket and pulled out the LED's and the circuit board

Sure enough , broken joints at the female connector to the circuit board.

Soldered with fine "silver solder" wire , rebuilt with windscreen ( sorry "windshield" haha) silicone sealant

carefully reassembled with electrical clean and lube on the wires and connectors

Working all good now , you can "tap" the light unit and no "flickering"

Only labour , your time , and a wee bit of materials.

It's a $300 light unit here in Perth Western Australia to order it from the HD dealer
Logged
 

Page created in 0.13 seconds with 26 queries.